Reactivate device

  • Hi guys,

    Is there any change in the t-mobile nb-iot network?
    I came back from holiday, then my nb-iot devices can’t register anymore. The modem is always return CSQ 99,99.

    I received an email on 8th Nov to activate the device with link http://gui.iot.tmobile.local:81/activate/SeaHLCZO3i59OXejKQW3Y2sENm0mWQNhiuh0zvJer6vzLVo7ZCX8UrnJKUV5TwQHHZ6aPJuAdyunQccootPvwZMZa7dV7f7lM3To. But it’s not working anymore, is that possible to send another activate link again.

    Is there a way to reactivate the device again?


  • You could possibly try to see if your device is registered in devreg as we have in the meantime updated the UI. If not add you IMEI as described, or delete and resubscribe see the doc below:

    Let me know if it helps…


  • @techniek said in Reactivate device:


    Thanks for the reply. I tried delete and re-add device again. But it is still the same. The following are the detailed output:

    –>nbiot: “AT+NCONFIG=CR_0354_0338_SCRAMBLING,FALSE”
    nbiot–> OK
    –>nbiot: “AT+NCONFIG=CR_0354_0338_SCRAMBLING,FALSE”
    nbiot–> OK
    –>nbiot: “AT+NCONFIG=CR_0859_SI_AVOID,FALSE”
    nbiot–> OK
    –>nbiot: “AT+NCONFIG?”
    nbiot–> +NCONFIG:CR_0354_0338_SCRAMBLING,FALSE
    nbiot–> +NCONFIG:CR_0859_SI_AVOID,FALSE
    nbiot–> OK
    –>nbiot: “AT+CFUN=0”
    nbiot–> OK
    –>nbiot: “AT+NCDP=”
    nbiot–> OK
    –>nbiot: “AT+CGDCONT=1,“IP”,“””
    nbiot–> OK
    –>nbiot: “AT+CFUN=1”
    nbiot–> OK
    –>nbiot: “AT+NBAND=8”
    nbiot–> OK
    –>nbiot: "AT+COPS=1,2,“20416"”
    nbiot–> OK
    –>nbiot: “AT+CSQ”
    nbiot–> +CSQ:99,99

    The CSQ is always 99,99.

    Then I checked the neuestats by sending:
    –>nbiot: “AT+NUESTATS=RADIO”
    nbiot–> NUESTATS:RADIO,Signal power:0
    nbiot–> NUESTATS:RADIO,Total power:-32767
    nbiot–> NUESTATS:RADIO,TX power:0
    nbiot–> NUESTATS:RADIO,TX time:0
    nbiot–> NUESTATS:RADIO,RX time:3602
    nbiot–> NUESTATS:RADIO,Cell ID:0
    nbiot–> NUESTATS:RADIO,ECL:0
    nbiot–> NUESTATS:RADIO,SNR:0
    nbiot–> NUESTATS:RADIO,PCI:0
    nbiot–> OK

    Is that possible to generate the link you guys sent before?

    Best regards

  • I don’t know… I will check tomorrow when I am in the office.

    In the meantime, out of curiosity, what type of device ar you using? I have seen some strange behavior some times with firmwares on the 02b of sodaq…
    If you are using sodaq, these command might help…

  • I’m using sodaq nb-iot shield. I tried those commands you listed but it’s still the same result. The response of the ‘ATI9’ command response is error.


  • Hi @kylett,

    That your device is not responding to ATI9 is strange… thats why I was inquiring about firmware info.

    Here’s a log from my device, you should see something similar:

    > AT+CGMI
    < U-blox A.G.; OK
    > AT+CGMM
    < SARA-N200 OK
    > AT+CGMR
    < 06.57 OK
    > ATI9
    < 06.57,A01.01 OK

    You might, if you havn’t done so yet, try to do a firmware upgrade:

    And if you have 01B board of ublox:

    Sorry, no news on the link.
    To my knowledge the only way to register your device is with the devreg tool…
    Or you can use the OceanConnect platform API calls.

    Kind regards,

  • Hi All,

    It looks like I have a similar problem. I have an N200 02B module from sodaq, the firmware version is 06.57, A03.02. How can I check if the device is registered? When I try to follow the link given by @techniek, I get an Access Denied error. In fact, I get the same for all manuals.

Log in to reply