cme error: 30 / cme error: no network service

  • Hi all,

    Since about a week we’ve been giving IoT connection a go with a RPI 4 + sixfab cellular IoT hat (Quectel BG96MA chip).
    After connecting the IoT hat with the RPI & inserting the sim, we tought we would be able to start sending AT commands like the documentation shows

    Everything seems fine until this command:

    After several minutes the minicom terminal says:
    +CME ERROR: no network service or without verbose messaging +CME ERROR: 30

    As the steps suggest, we’ve registered the IMEI of our Quectel BG96MA chip within our T-mobile IoT platform, hoping this would be fine.

    Things we’ve tried:

    1. Configuring following the steps from this document
    2. Configuring following these steps. But since some of the commands aren’t usable with the Quectel BG96 chip, we sort of got stuck there.
    3. This is until the last 2 steps, “successful”.
    4. This didn’t help us that much, but we’ve tried anyway.
    5. Tried some of the steps in this document but since it is for a different chip, we didn’t succeed.

    We think that there is some configuration error somewhere in our files, but we are currently stuck and haven’t got a clue on how to fix this issue.

    Thank you in advance!

  • Edit:
    Just after posting, I struck upon this topic and was able to succesfully connect.
    Now I’am figuring out how to setup the socket and start sending Hello world! messages.

    I will do my best to keep you updated!