QUECTEL BC95-B8 not connecting to Network



  • Hi, I’ve bought a dev kit with the QUECTEL BC95-B8 and trying to connect it to the network in Germany. I first tried the Tutorial for the SARA N211, which was recommendet here, but a lot of the commands are not available (always getting ERROR as response). After some more googling I’ve found this PDF file which describes the connecting with the exact same firmware as my device has, but I stuck at the point where I have to wait for the attachment.

    Output of at+nuestats:

    Signal power:0
    Total power:-32767
    TX power:0
    TX time:0
    RX time:1226182
    Cell ID:0
    DL MCS:0
    UL MCS:0
    DCI MCS:0
    ECL:0
    SNR:0
    EARFCN:0
    PCI:0
    


  • This is the Dev Board: https://www.quectel.com/product/gsmevb.htm
    I tried also getting data from the Debug Serial, but the bitrate from the manual doesn’t work



  • OK, I’ve got the log viewer and the network working (I get a signal), but my device gets rejetet. The rejection status in UE Log Viewer is EMM_CAUSE_UNKNOWN



  • @jonasled Can you check if you have a working SIM card? Try AT+CPIN?

    It should return OK



  • @Stefan-de-Lange said in QUECTEL BC95-B8 not connecting to Network:

    AT+CPIN?

    AT+CPIN? returns error, but this can also be caused by the module, because there are a lot of commands producing errors.



  • But the card gets detectetd, becauser AT+CIMI returns the number



  • @jonasled You can enable more verbose error reporting with AT+CMEE=2. That will tell you what kind of error you have.

    Quectel usually has their own version for every command so SARA N211 commands will not work.

    What I can think of:

    • Make sure you have the latest firmware
    • Make sure the SIM works (try with a different module?)
    • Make sure the antenna is properly connected
    • Make sure you are in range of a network (scan with AT+COPS=?)
    • Make sure you have a proper powersupply/cable (especially some USB supplies can be bad)
    • Make sure you have the correct LTE bands enabled
    • It should autoconnect to an available network but if it doesn’t you can force it with AT+COPS


  • @Stefan-de-Lange said in QUECTEL BC95-B8 not connecting to Network:

    AT+COPS

    Thank you for the quick answer, AT+CMEE=2 is not working, I can only select between 0 and 1, firmware updating is also not possible, because I can’t find any firmware online (I’ve already contacted Quectel, but no answer at the moment). I also don’t have another device to test the card. But it looks like that I have a signal:

    AT+NUESTATS
    Signal power:-1004
    Total power:-873
    TX power:23
    TX time:27010
    RX time:358251
    Cell ID:31251973
    DL MCS:0
    UL MCS:0
    DCI MCS:0
    ECL:2
    SNR:-20
    EARFCN:3740
    PCI:58
    
    OK
    AT+COPS?
    +COPS:0,2,""
    
    OK
    AT+COPS=?
    +COPS:(2,,,"26201"),,(0-2),(2)
    
    OK
    AT+NCONFIG?
    +NCONFIG:AUTOCONNECT,TRUE
    +NCONFIG:CR_0354_0338_SCRAMBLING,TRUE
    +NCONFIG:CR_0859_SI_AVOID,TRUE
    
    OK
    AT+CSQ
    +CSQ:13,99
    
    OK
    AT+NBAND?
    +NBAND:8
    
    OK
    AT+CEREG?
    +CEREG:0,2
    
    OK
    AT+CGATT?
    +CGATT:0
    
    OK
    
    


  • @jonasled “EMM_CAUSE_UNKNOWN” is hard to diagnose. Any time I have seen this error it could either be some operator issue, a SIM issue or a modem FW related issue. So I would suggest to update the FW first and then try again 🙂



  • Do you know where to get the firmware update. I’ve seen here a link to a nextcloud from telekom, but it doesn’t exist anymore.



  • @jonasled I got mine through a supplier. So try asking the company you bought the devkit from. I do not like how quectel handles this, it is very inconvenient and old fashioned…



  • The problem is, I bought this from a private person used on ebay. I hope they answer next week on my mail.