SIM7020E has trouble entering PSM



  • Hello everyone,

    I have a question regarding entering PSM mode.
    I am using the SIM7020E module to send out data using UDP.
    Afterwards, when instructing to go into PSM, the module responds with:

    AT+CPSMS=1
    OK

    But the +CPSMSTATUS: “ENTER PSM” message sometimes takes a long time to appear.
    In some cases this can even take more then a minute…

    It looks like the timing of this command has some influece, and I was therefore wondering if there is any protocol or guideline for entering and exiting PSM mode from the network side.

    What could be the case for the network accepting my PSM request so late sometimes?


  • Deutsche Telekom IoT

    Hi MeneerJacco,
    I don’t know the exact answer for you, I apologise. But didn’t want to let you waiting either. May I provide you with a link for further technical deep-dive on the matter: please look at our technology cards here

    You will find a lot of knowledge around power saving features, just open the required section
    pic.jpg
    In case that didn’t help you please reach out again and I’m gonna find someone on our end on Monday.
    Have a nice weekend,
    Uta



  • Hello @Uta,

    I did not know of the Technology Cards.
    I will take a look at PSM and the other topics.

    Thank you very much.


  • Deutsche Telekom IoT

    Hi MeneerJacco,

    You may want to specify the PSM Timer value to be used before entering Power Saving.
    If you want the module to enter PSM right after leaving its connected mode, use for instance the command:

    AT+CPSMS=1,,,,"00000000"
    

    You may also want to provide a longer TAU timer. To configure for instance a TAU Timer of 3 hours and a PSM of 0s, enter:

    AT+CPSMS=1,,,"00100011","00000000"
    

    Best,

    Ronan



  • Hello @Ronan-Lacroix ,

    That is very helpful information.
    I will try that and see if it speeds up the process :).

    Thank you very much