Application Server



  • I have attached a device to send data and can confirm the data is arriving at IotCreators platform.
    I tried out the application server functionality using the example with beeceptor and all works well.

    Now I want to forward the data to https://api.allthingstalk.io/proxy/network/tmobilenl as a further test.
    Similar to these steps:
    https://www.hackster.io/voske65/arduino-nb-iot-with-sim7020-and-t-mobile-027f8f#toc-send-data-5

    I thought I could have just replaced the url to Beeceptor but I keep getting an error that the URL is invalid.
    I then tried to add this extra URL via the API and I got a positive response back from the server so I am assuming I now have two application servers configured?
    Is my understanding correct that I cannot view or change these application server settings via the portal nor the API?

    Since I have no data arriving at the destination I wanted to troubleshoot the configuration and verify that data is being sent but I don’t see any logging possibilities on the site.

    Am I missing something? How are others working with the platform?


  • Deutsche Telekom IoT

    I think that you did everything right. Something has changed at All Things Talk’s end. We received more complaints about integrations with ATT.

    @Eric-Barten already contacted them, but I will give it another try next week.


  • Deutsche Telekom IoT

    @Colin-Chalmers

    It took some time, but we’ve tested it and it should work again



  • @afzal_m Thats good news, but I don’t see any change in functionality yet. As in I don’t see data arriving at AllThingsTalk. I need to test something else first before I draw conclusions



  • @Colin-Chalmers ok, I’ve just checked a couple of things. I can send and am receiving data on IoTCreators site. I have configured the Application Server to use the AllThingsTalk callback. I have configured a device in the AllThingsTalk platform. However no data seems to be coming in and the device remains in the state inactive.


  • Deutsche Telekom IoT

    Hmm ok but the error “invalid URL” is gone right?



  • @afzal_m Apologies, I may have spoken too soon.
    After playing with the payload formats on AllThingsTalk I do now see information coming in. Not quite exactly what i expected but I guess that’s down to misconfiguration on my part. So I’d say yes the connection works, parsing of data I need to look into.

    And yes changing the URL on the application server works which is good news! 🙂