IP for CoAP



  • I’m trying to get CoAP to work with my BK7020, and I can’t find the IP I need to connect with.

    I’m following the application note at https://simcom.ee/documents/SIM7020/SIM7020%20Series_CoAP_Application%20Note_V1.02.pdf, and specifically need the IP for the AT+CCOAPNEW command at page 6. There’s a bunch of IPs and ports scattered around the documentation, but none of them seem to work here. I’m assuming the port I need is 15683

    Any suggestions? Right now I’m not getting my +CCOAPNMI: so I assume my IP/ports aren’t configured correctly.

    I’ve registered my device with “TMNL_COAP_AL” as the adaptationLayerName



  • @IoT-Arista The documentation says CoAP is available at ip address: 172.27.131.100, port: 5683

    https://docs.iotcreators.com/docs/general-settings



  • @Stefan-de-Lange said in IP for CoAP:

    172.27.131.100

    Thanks! That didn’t work yet, but at least now I know the problem lies somewhere else in my system.

    Also btw, Google lists a lot of results from docs.iot.t-mobile.nl/* that seem to be stale. Following any link in that domain from google (for example https://docs.iot.t-mobile.nl/docs/developer-documentation) gives me the following warning that I can’t dismiss and bypass:
    1bed09e5-2b63-41d4-8528-133102cb7c66-image.png
    Same error copying the link address and pasting it in a new tab. In firefox I get a 403 forbidden error from cloudflare.

    I can search using your built-in search in the documentation so it’s not really a problem, but it’s been like that for a while so I thought I’d let you know in case you weren’t aware.


  • Deutsche Telekom IoT

    @IoT-Arista Hi, thanks for letting us know! We moved our documentation library to docs.iotcreators.com - but I think you figured that out. I will try to figure out if we can change or remove the broken links from google search. Thank you!


Log in to reply