LTE-M Connection Problem with BG96



  • Hi,
    I’m trying to connect to the LTE CAT M1 with BG96 , here is the set of AT commands that I used (see below) and the log responses. I expected at the end maybe couple of times 2, as the response to the command “at+cereg?” then it should connect and gives 5 back. But I recieve 2 couple of times then it even dosen’t search anymore and gives 0 back!

    Dose anyone have an idea what could be causing this?

    Regards,
    Kurosh

    08:57:19.196 -> at+cfun=1
    
    08:57:20.489 -> OK
    08:57:20.489 -> at+cpin?
    
    08:57:20.489 -> +CPIN: READY
    08:57:20.489 -> 
    08:57:20.489 -> OK
    08:57:20.806 -> at+cfun=0
    
    08:57:20.848 -> OK
    08:57:22.095 -> ATI
    
    08:57:22.095 -> Quectel
    08:57:22.095 -> BG96
    08:57:22.095 -> Revision: BG96MAR02A07M1G
    08:57:22.095 -> 
    08:57:22.095 -> OK
    08:57:23.416 -> at+gsn
    
    08:57:23.416 -> 860536040710222
    08:57:23.416 -> 
    08:57:23.416 -> OK
    08:57:24.707 -> at+qcfg="nwscanseq",020202,1
    
    08:57:24.707 -> OK
    08:57:25.988 -> at+qcfg="nwscanmode", 3,1
    
    08:57:25.988 -> OK
    08:57:27.320 -> at+qcfg="iotopmode",0,1
    
    08:57:27.320 -> OK
    08:57:28.599 -> at+qcfg="band",0,80000,0
    
    08:57:28.599 -> OK
    08:57:29.894 -> at+qcfg="roamservice",255,1
    
    08:57:29.894 -> OK
    08:57:31.216 -> at+qcfg="servicedomain",1,1
    
    08:57:31.216 -> OK
    08:57:32.505 -> at+cgdcont=1,"IP","internet.nbiot.telekom.de"
    
    08:57:32.505 -> OK
    08:57:33.783 -> at+cfun=1
    
    08:57:35.090 -> OK
    08:57:35.090 -> at+cops=?
    
    08:57:36.603 -> +COPS: (1,"Vodafone.de","Vodafone","26202",8),(1,"Vodafone.de","Vodafone","26202",8),(1,"Vodafone.de","Vodafone","26202",8),(1,"Telekom.de","TDG","26201",8),(1,"Telekom.de","TDG","26201",8),(1,"Telekom.de","TDG","26201",8),,(0,1,2,3,4),(0,1,2)
    08:57:36.637 -> 
    08:57:36.637 -> OK
    08:57:41.198 -> at+cops=1,2,"26201",8
    
    08:57:44.283 -> OK
    08:57:47.371 -> at+cind?
    
    08:57:47.405 -> +CIND: 0,4,0,0,1,0,0,0
    08:57:47.405 -> 
    08:57:47.405 -> OK
    08:57:50.698 -> at+cereg?
    
    08:57:50.698 -> +CEREG: 0,2
    08:57:50.698 -> 
    08:57:50.698 -> OK
    08:57:53.981 -> at+cereg?
    
    08:57:53.981 -> +CEREG: 0,2
    08:57:53.981 -> 
    08:57:53.981 -> OK
    08:57:57.281 -> at+cereg?
    
    08:57:57.281 -> +CEREG: 0,2
    08:57:57.281 -> 
    08:57:57.281 -> OK
    08:58:00.579 -> at+cereg?
    
    08:58:00.579 -> +CEREG: 0,0
    08:58:00.579 -> 
    08:58:00.579 -> OK
    08:58:03.871 -> at+cereg?
    
    08:58:03.871 -> +CEREG: 0,0
    08:58:03.871 -> 
    08:58:03.871 -> OK
    08:58:07.188 -> at+cereg?
    
    08:58:07.188 -> +CEREG: 0,0
    08:58:07.188 -> 
    08:58:07.188 -> OK
    08:58:10.489 -> at+cereg?
    
    08:58:10.489 -> +CEREG: 0,0
    08:58:10.489 -> 
    08:58:10.489 -> OK
    
    
    

  • Deutsche Telekom IoT

    Hi Kurosh,
    08:57:32.505 -> at+cgdcont=1,“IP”,“internet.nbiot.telekom.de”
    this APN is for NB-IoT only.
    For LTE-M you can use the APN internet.m2mportal.de.

    I suspect that between 08:57:57.281 and 08:58:00.579 you get a +CEREG: 0,3 (rejected from network)?
    Regards, Uta



  • @Uta said in LTE-M Connection Problem with BG96:

    APN internet.m2mportal.de

    Thank you so much for the answer. It worked after I changed the APN.



  • @Uta
    Hi Uta,

    I wanted also to test the NB connection which did’t work for me and I switched back to the configuration for LTE-M. Now It dosen’t even connect anymore with the lTE-M config. I recieve CME ERROR 13 which is really strange! I wonder what I’m missing here!

    Kind regards,
    Kurosh

    08:07:46.615 -> at+cpin?
    
    08:07:46.615 -> +CPIN: READY
    08:07:46.667 -> 
    08:07:46.667 -> OK
    08:07:46.948 -> at+cfun=0
    
    08:07:47.000 -> OK
    08:07:48.248 -> ATI
    
    08:07:48.248 -> Quectel
    08:07:48.248 -> BG96
    08:07:48.248 -> Revision: BG96MAR02A07M1G
    08:07:48.248 -> 
    08:07:48.248 -> OK
    08:07:49.532 -> at+gsn
    
    08:07:49.532 -> 860536040826531
    08:07:49.532 -> 
    08:07:49.532 -> OK
    08:07:50.834 -> at+qcfg="nwscanseq",020202,1
    
    08:07:50.834 -> OK
    08:07:52.166 -> at+qcfg="nwscanmode", 3,1
    
    08:07:52.166 -> OK
    08:07:53.417 -> at+qcfg="iotopmode",0,1
    
    08:07:53.417 -> OK
    08:07:54.757 -> at+qcfg="band",0,80000,0
    
    08:07:54.757 -> OK
    08:07:56.030 -> at+qcfg="roamservice",255,1
    
    08:07:56.030 -> OK
    08:07:57.346 -> at+qcfg="servicedomain",1,1
    
    08:07:57.346 -> OK
    08:07:58.659 -> at+cgdcont=1,"IP","internet.m2mportal.de"
    
    08:07:58.659 -> OK
    08:07:59.948 -> at+cfun=1
    
    08:08:01.248 -> OK
    08:08:01.248 -> at+cops=?
    
    08:08:02.831 -> +COPS: (1,"Telekom.de","TDG","26201",8),(1,"Telekom.de","TDG","26201",8),(1,"Vodafone.de","Vodafone","26202",8),(1,"Vodafone.de","Vodafone","26202",8),(1,"Vodafone.de","Vodafone","26202",8),(1,"Telekom.de","TDG","26201",8),,(0,1,2,3,4),(0,1,2)
    08:08:02.878 -> OK
    08:08:07.346 -> at+cops=1,2,"26201",8
    08:08:44.551 -> at+cops=1,2,"26201",8
    08:08:50.717 -> at+cops=1,2,"26201",8
    08:08:56.936 -> +CME ERROR: 13
    
    

  • Deutsche Telekom IoT

    Hi Kurosh, in Germany, Deutsche Telekom uses band 20 for LTE-M.
    See here



  • @Uta thank you for your fast reply! I indeed used B20. According to the Quectel’s Manual 80000 should be set for the B20. ( at+qcfg=“band”,0,80000,0 --> Screenshot)

    Screen Shot 2021-03-22 at 9.20.05 AM.png


  • Deutsche Telekom IoT

    @Kurosh said in LTE-M Connection Problem with BG96:

    08:08:07.346 -> at+cops=1,2,“26201”,8

    why does it show “8”?



  • @Uta I guess it stands for LTE-M for example in AT+COPS= 1,2, “26201”, 8 —> here the 8 is used to set LTE-M.
    So my guess is that it responses at+cops? with the same coding numbers as well!

    Screen Shot 2021-03-22 at 9.56.24 AM.png


  • Deutsche Telekom IoT

    Hi Kurosh,

    In an earlier message when you changed the APN it was working fine. Is there anything you changed since than? In general your AT commands seem fine.

    Can you please do the following:

    Turn off the radio with AT+CFUN=0. Do a AT+CEREG=3 and AT+QCSCON=1 (or if that doesn’t work use AT+CSCON=1). This will automatically print URC messages giving us an indication about what the module is doing. You should see automatic +CEREG and +CSCON messages arriving on your screen when you try to attach. If that doesn’t happen, your URC Indication configuration is not correct. Try using the command AT+QURCCFG=“urcport”,[“usbat” or “usbmodem” or “uart1”]. This depends on which serial port you are using so just try out one after the other, reboot the module and see if you get the URCs (an indication that it’s configured correctly is that you get a +CPIN: READY automatically printed on the screen when the module boots up.)

    After that please send the logs so we can try to figure out what is going wrong.

    Best
    Yassine



  • @Yassine-Amraue
    Hi Yassine,
    Thank you for your reply. Here is what I recieved from the commands you suggested:

    12:43:30.692 -> at+cfun=0
    
    12:43:30.739 -> OK
    12:43:32.005 -> at+cereg=3
    
    12:43:32.005 -> ERROR
    12:43:33.317 -> at+qcscon=1
    
    12:43:33.317 -> OK
    12:43:34.583 -> at+cscon=1
    
    12:43:34.583 -> ERROR
    
    

    I also tried similar commands (basically the same commands but with question mark instead):

    12:56:38.725 -> at+cpin?
    
    12:56:38.725 -> +CPIN: READY
    12:56:38.725 -> 
    12:56:38.725 -> OK
    12:56:39.006 -> at+cfun=0
    
    12:56:39.053 -> OK
    12:56:40.319 -> at+cereg?
    
    12:56:40.319 -> +CEREG: 0,0
    12:56:40.319 -> 
    12:56:40.319 -> OK
    12:56:41.631 -> at+qcscon?
    
    12:56:41.631 -> +QCSCON:0,0
    12:56:41.631 -> 
    12:56:41.631 -> OK
    12:56:42.944 -> at+qurccfg=?
    
    12:56:42.944 -> +QURCCFG: "urcport",("usbat","usbmodem","uart1")
    
    


  • @Yassine-Amraue
    I just tried to connect with NB instead which didn’t work either! Is Something wrong in my configs?

    at+cpin?
    
    +CPIN: READY
    
    OK
    at+cfun=0
    
    OK
    ATI
    
    Quectel
    BG96
    Revision: BG96MAR02A07M1G
    
    OK
    at+gsn
    
    860536040812077
    
    OK
    at+qcfg="nwscanseq",030303,1
    
    OK
    at+qcfg="nwscanmode", 3,1
    
    OK
    at+qcfg="iotopmode",1,1
    
    OK
    at+qcfg="band",0,0,80
    
    OK
    at+qcfg="roamservice",255,1
    
    OK
    at+qcfg="servicedomain",1,1
    
    OK
    at+cgdcont=1,"IP","internet.nbiot.telekom.de"
    
    OK
    at+cfun=1
    
    OK
    at+cops=?
    
    +CME ERROR: 3
    at+cops=1,2,"26201",9
    
    OK
    at+cind?
    
    +CIND: 0,0,0,0,0,0,0,0
    
    OK
    at+cereg?
    
    +CEREG: 0,0
    

  • Deutsche Telekom IoT

    @Kurosh

    I don’t see the URCs arriving at your screen. As described in my last message, please configure your URC port.
    If it is configured correctly you should see something like this:

    ate0 
    ate0
    
    OK
    
    at+cfun=0 
    
    OK
    
    at+qcscon=1 
    
    OK
    
    at+cereg=2 
    
    OK
    
    at+cfun=1 
    
    OK
    
    +CPIN: READY
    
    +QUSIM: 1
    
    +QIND: SMS DONE
    
    at+cops=1,2,"26201",8 
    
    OK
    
    +QCSCON: 1,1
    
    +CEREG: 5,"6F55","18CB40E",8
    
    +QCSCON: 1,0
    
    +CEREG: 5,"6F55","18CB404",8
    

    Notice that the +QCSCON: 1,1 and +CEREG: 5,“6F55”,“18CB40E”,8 pop up automatically.
    Also right after turning on the radio with AT+CFUN=1 you can see

    +CPIN: READY
    
    +QUSIM: 1
    
    +QIND: SMS DONE
    

    popping up automatically. I dont see that in your logs. Please configure your URC port and issue the commands as I’ve shown in the example here.

    Best
    Yassine